: Log in!

メインメニュー
Google


ウェブ 検索
サイト内検索
トップ  >  Linux14歩  >  2014-06-28 phpのupdate
20140628 php-5.4.30にupdateしました


Changelog

Version 5.4.30
26-Jun-2014

. Core:
  . Fixed BC break introduced by patch for bug #67072.
  . Fixed bug #66622 (Closures do not correctly capture the late bound class (static::) in some cases).
  . Fixed bug #67390 (insecure temporary file use in the configure script) (CVE-2014-3981).
  . Fixed bug #67399 (putenv with empty variable may lead to crash).
  . Fixed bug #67498 (phpinfo() Type Confusion Information Leak Vulnerability).
. CLI server:
  . Fixed bug #67406 (built-in web-server segfaults on startup).
. Date:
  . Fixed bug #67308 (Serialize of DateTime truncates fractions of second).
  . Fixed regression in fix for bug #67118 (constructor can't be called twice).
. Fileinfo:
  . Fixed bug #67326 (fileinfo: cdf_read_short_sector insufficient boundary check) (CVE-2014-0207).
  . Fixed bug #67410 (fileinfo: mconvert incorrect handling of truncated pascal string size) (CVE-2014-3478).
  . Fixed bug #67411 (fileinfo: cdf_check_stream_offset insufficient boundary check) (CVE-2014-3479).
  . Fixed bug #67412 (fileinfo: cdf_count_chain insufficient boundary check) (CVE-2014-3480).
  . Fixed bug #67413 (fileinfo: cdf_read_property_info insufficient boundary check) (CVE-2014-3487).
. Intl:
  . Fixed bug #67349 (Locale::parseLocale Double Free).
  . Fixed bug #67397 (Buffer overflow in locale_get_display_name and uloc_getDisplayName (libicu 4.8.1)).
    Network:
  . Fixed bug #67432 (Fix potential segfault in dns_get_record()) (CVE-2014-4049).
. OpenSSL:
  . Fixed bug #65698 (certificates validity parsing does not work past 2050).
  . Fixed bug #66636 (openssl_x509_parse warning with V_ASN1_GENERALIZEDTIME).
. SOAP:
  . Implemented FR #49898 (Add SoapClient::__getCookies()).
. SPL:
  . Fixed bug #66127 (Segmentation fault with ArrayObject unset).
  . Fixed bug #67359 (Segfault in recursiveDirectoryIterator).
  . Fixed bug #67360 (Missing element after ArrayObject::getIterator).
  . Fixed bug #67492 (unserialize() SPL ArrayObject / SPLObjectStorage Type Confusion) (CVE-2014-3515).
投票数:28 平均点:6.07
前
2014-06-27 sambaのupdate
カテゴリートップ
Linux14歩
次
2014-07-19 lynisのupdate