: Log in!

メインメニュー
Google


ウェブ 検索
サイト内検索
トップ  >  Linux16歩  >  2016-02-20 phpのupgrade
20160220 php-5.6.18にupgradeしました


5.4から5.6へ

・apacheのmpm_eventで動かすには--enable-maintainer-ztsオプションが必要です

・extension_dir のデフォルト値が変わっています
 extension_dir = "/usr/local/lib/php/extensions/no-debug-zts-20131226/"

・iconv および mbstring の、エンコーディングに関するオプションが非推奨となりました
 代わりに default_charset を使いましょう

・MySQL 拡張モジュール が非推奨になりました
 代わりに MySQLi あるいは PDO_MySQL を使いましょう
 MySQL ライブラリには libmysqlclient の代わりに mysqlnd を使いましょう

・OPcacheがデフォルトで組み込まれますが、拡張モジュールとしてしかコンパイルできません
 zend_extensionで OPcache を PHP にロードします

・その他

PHP 5.4.x から PHP 5.5.x への移行を参照してください

PHP 5.5.x から PHP 5.6.x への移行を参照してください

投票数:7 平均点:10.00
前
2016-02-20 httpdのupgrade
カテゴリートップ
Linux16歩
次
2016-02-24 postfixのupdate